const regex = new RegExp('\\[
(?<tag>\\w+) \\s*
(?:=\\s*
(?:
(?<quote>["\\']) (?<arg>.{0,100}?) \\k<quote>
| (?<arg>[^\\]]+)
)
)?
\\]
(?<content>
(?:[^[]++ | (?R) )*+
)
\\[/\\k<tag>\\]', 'gi')
const str = `[spoiler]content[/spoiler], [spoiler=option]content[/spoiler] and [spoiler="option"]content[/spoiler]
[a] foo [b] bar [/b] baz [/a]
[a=foo] foo [b] bar [/b] baz [/a]
[a="foo"] foo [b] bar [/b] baz [/a]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}