re = /\[
(?<tag>\w+) \s*
(?:=\s*
(?:
(?<quote>["']) (?<arg>.{0,100}?) \k<quote>
| (?<arg>[^\]]+)
)
)?
\]
(?<content>
(?:[^[]++ | (?R) )*+
)
\[\/\k<tag>\]/xi
str = '[spoiler]content[/spoiler], [spoiler=option]content[/spoiler] and [spoiler="option"]content[/spoiler]
[a] foo [b] bar [/b] baz [/a]
[a=foo] foo [b] bar [/b] baz [/a]
[a="foo"] foo [b] bar [/b] baz [/a]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end