// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?xi)\[
(?<tag>\w+) \s*
(?:=\s*
(?:
(?<quote>["']) (?<arg>.{0,100}?) \k<quote>
| (?<arg>[^\]]+)
)
)?
\]
(?<content>
(?:[^[]++ | (?R) )*+
)
\[/\k<tag>\]"#).unwrap();
let string = "[spoiler]content[/spoiler], [spoiler=option]content[/spoiler] and [spoiler=\"option\"]content[/spoiler]
[a] foo [b] bar [/b] baz [/a]
[a=foo] foo [b] bar [/b] baz [/a]
[a=\"foo\"] foo [b] bar [/b] baz [/a]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}