import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\n"
+ " (?<tag>\\w+) \\s*\n"
+ " (?:=\\s*\n"
+ " (?:\n"
+ " (?<quote>[\"']) (?<arg>.{0,100}?) \\k<quote>\n"
+ " | (?<arg>[^\\]]+)\n"
+ " )\n"
+ " )?\n"
+ "\\]\n\n"
+ "(?<content>\n"
+ " (?:[^[]++ | (?R) )*+\n"
+ ")\n\n"
+ "\\[/\\k<tag>\\]";
final String string = "[spoiler]content[/spoiler], [spoiler=option]content[/spoiler] and [spoiler=\"option\"]content[/spoiler]\n\n"
+ "[a] foo [b] bar [/b] baz [/a]\n"
+ "[a=foo] foo [b] bar [/b] baz [/a]\n"
+ "[a=\"foo\"] foo [b] bar [/b] baz [/a]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}