#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im);(?!(?:"[^"]*"|[^"])*$)"
Local $sString = "asbas;"asd;";asd;asdadasd;"asd;ad;s;as""
Local $sSubst = ":"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)