import re
regex = re.compile(r";(?!(?:\"[^\"]*\"|[^\"])*$)", flags=re.IGNORECASE | re.MULTILINE)
test_str = "asbas;\"asd;\";asd;asdadasd;\"asd;ad;s;as\""
subst = ":"
result = regex.sub(subst, test_str)
if result:
print(result)