#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).{3}_.*\d{3}"
Local $sString = "This field has lots of text and also what I need to extract from it which is 555_AB345678"" & @CRLF & _
"This field has lots of text and also what I need to extract from it which is 555_AB345678 This field has lots of text and" & @CRLF & _
"This field has lots of text and also what I need to extract from it which is 555_AB345678This field has lots of text and" & @CRLF & _
"555_AB345678This field has lots of text and" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")