use strict;
my $str = 'This field has lots of text and also what I need to extract from it which is 555_AB345678"
This field has lots of text and also what I need to extract from it which is 555_AB345678 This field has lots of text and
This field has lots of text and also what I need to extract from it which is 555_AB345678This field has lots of text and
555_AB345678This field has lots of text and
';
my $regex = qr/.{3}_.*\d{3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}