using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".{3}_.*\d{3}";
string input = @"This field has lots of text and also what I need to extract from it which is 555_AB345678""
This field has lots of text and also what I need to extract from it which is 555_AB345678 This field has lots of text and
This field has lots of text and also what I need to extract from it which is 555_AB345678This field has lots of text and
555_AB345678This field has lots of text and
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}