$re = '/.{3}_.*\d{3}/m';
$str = 'This field has lots of text and also what I need to extract from it which is 555_AB345678"
This field has lots of text and also what I need to extract from it which is 555_AB345678 This field has lots of text and
This field has lots of text and also what I need to extract from it which is 555_AB345678This field has lots of text and
555_AB345678This field has lots of text and
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);