import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".{3}_.*\\d{3}";
final String string = "This field has lots of text and also what I need to extract from it which is 555_AB345678\"\n"
+ "This field has lots of text and also what I need to extract from it which is 555_AB345678 This field has lots of text and\n"
+ "This field has lots of text and also what I need to extract from it which is 555_AB345678This field has lots of text and\n"
+ "555_AB345678This field has lots of text and\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}