package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@(.*?)\(\(property\((.*?)\)val\((.*?)\)\)`)
var str = `MyCarGarage@Mustang((property(PS)val(500))@Porsche((property(PS)val(425)).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}