$re = '/@(.*?)\(\(property\((.*?)\)val\((.*?)\)\)/';
$str = 'MyCarGarage@Mustang((property(PS)val(500))@Porsche((property(PS)val(425)).';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);