const regex = /@(.*?)\(\(property\((.*?)\)val\((.*?)\)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@(.*?)\\(\\(property\\((.*?)\\)val\\((.*?)\\)\\)', 'g')
const str = `MyCarGarage@Mustang((property(PS)val(500))@Porsche((property(PS)val(425)).`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}