using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"jon(?! snow)|jon snow|lana(?! smith)|(?<!lana )smith|lana smith|megan";
string input = @"Jon Snow and Lana Smith met up with Lana and Megan";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}