const regex = /jon(?! snow)|jon snow|lana(?! smith)|(?<!lana )smith|lana smith|megan/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('jon(?! snow)|jon snow|lana(?! smith)|(?<!lana )smith|lana smith|megan', 'gi')
const str = `Jon Snow and Lana Smith met up with Lana and Megan`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}