re = /jon(?! snow)|jon snow|lana(?! smith)|(?<!lana )smith|lana smith|megan/i
str = 'Jon Snow and Lana Smith met up with Lana and Megan'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end