$re = '/jon(?! snow)|jon snow|lana(?! smith)|(?<!lana )smith|lana smith|megan/i';
$str = 'Jon Snow and Lana Smith met up with Lana and Megan';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);