use strict;
my $str = 'Jon Snow and Lana Smith met up with Lana and Megan';
my $regex = qr/jon(?! snow)|jon snow|lana(?! smith)|(?<!lana )smith|lana smith|megan/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}