using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!([01]?\d|2[0-3]):[0-5]\d$).*";
string input = @"08:00
09:00
9:00
13:00
23:59
10.00
24:00
25:30
23:62
afdasdasd
ten";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}