use strict;
my $str = '08:00
09:00
9:00
13:00
23:59
10.00
24:00
25:30
23:62
afdasdasd
ten';
my $regex = qr/^(?!([01]?\d|2[0-3]):[0-5]\d$).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}