$re = '/^(?!([01]?\d|2[0-3]):[0-5]\d$).*/m';
$str = '08:00
09:00
9:00
13:00
23:59
10.00
24:00
25:30
23:62
afdasdasd
ten';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);