import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!([01]?\\d|2[0-3]):[0-5]\\d$).*";
final String string = "08:00\n"
+ "09:00\n"
+ "9:00\n"
+ "13:00\n"
+ "23:59\n"
+ "10.00\n"
+ "24:00\n"
+ "25:30\n"
+ "23:62\n"
+ "afdasdasd\n"
+ "ten";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}