const regex = /^(?!([01]?\d|2[0-3]):[0-5]\d$).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!([01]?\\d|2[0-3]):[0-5]\\d$).*', 'gm')
const str = `08:00
09:00
9:00
13:00
23:59
10.00
24:00
25:30
23:62
afdasdasd
ten`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}