# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([-\w]+\s+[-\w]+)\s+Inc/\1/gi;t' <<< "Random Inc
A Non-Random Inc"