import re
regex = re.compile(r"([-\w]+\s+[-\w]+)\s+Inc", flags=re.IGNORECASE)
test_str = ("Random Inc\n"
"A Non-Random Inc")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)