$re = '/([-\w]+\s+[-\w]+)\s+Inc/i';
$str = 'Random Inc
A Non-Random Inc';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;