using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([-\w]+\s+[-\w]+)\s+Inc";
string substitution = @"\1";
string input = @"Random Inc
A Non-Random Inc";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}