re = /([-\w]+\s+[-\w]+)\s+Inc/i
str = 'Random Inc
A Non-Random Inc'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result