#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\'.*(test).*\'"
Local $sString = "Some sample text," & @CRLF & _
"'this is test a match' and" & @CRLF & _
"'test' something" & @CRLF & _
"'this is not a match' but" & @CRLF & _
"'this is a match again because it contains the word test'." & @CRLF & _
"This "is not a test match because its double quotes"." & @CRLF & _
"And this is not a test match either because this is not encapsulated in quotes."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")