use strict;
my $str = 'Some sample text,
\'this is test a match\' and
\'test\' something
\'this is not a match\' but
\'this is a match again because it contains the word test\'.
This "is not a test match because its double quotes".
And this is not a test match either because this is not encapsulated in quotes.';
my $regex = qr/\'.*(test).*\'/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}