package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\'.*(test).*\'`)
var str = `Some sample text,
'this is test a match' and
'test' something
'this is not a match' but
'this is a match again because it contains the word test'.
This "is not a test match because its double quotes".
And this is not a test match either because this is not encapsulated in quotes.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}