import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\'.*(test).*\\'";
final String string = "Some sample text,\n"
+ "'this is test a match' and\n"
+ "'test' something\n"
+ "'this is not a match' but\n"
+ "'this is a match again because it contains the word test'.\n"
+ "This \"is not a test match because its double quotes\".\n"
+ "And this is not a test match either because this is not encapsulated in quotes.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}