re = /\'.*(test).*\'/
str = 'Some sample text,
\'this is test a match\' and
\'test\' something
\'this is not a match\' but
\'this is a match again because it contains the word test\'.
This "is not a test match because its double quotes".
And this is not a test match either because this is not encapsulated in quotes.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end