#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[ \(\w+\)]" & @CRLF & _
""
Local $sString = "x (LOC)" & @CRLF & _
"ds ds (32C)" & @CRLF & _
"d'ds ds (LeC)" & @CRLF & _
"ds-d da(LOQ)" & @CRLF & _
"12345 (deC)" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")