re = /[ \(\w+\)]
/
str = 'x (LOC)
ds ds (32C)
d\'ds ds (LeC)
ds-d da(LOQ)
12345 (deC)
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end