package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[ \(\w+\)]
`)
var str = `x (LOC)
ds ds (32C)
d'ds ds (LeC)
ds-d da(LOQ)
12345 (deC)
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}