import re
regex = re.compile((r"[ \(\w+\)]\n"))
test_str = ("x (LOC)\n"
"ds ds (32C)\n"
"d'ds ds (LeC)\n"
"ds-d da(LOQ)\n"
"12345 (deC)\n\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")