package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\s*(https?:\/\/[^\]\s]+)\s+([^\[\]]*)\[\[([^\]\|]+)(?:\|[^\]]*)?\]\]\s+(.*)\]`)
var str = `[http://www.catalogueoflife.org/annual-checklist/2011/search/all/key/Typhlodromips+digitulus/match/1 Typhlodromips digitulus [[Catalogue of Life]] saytında]`
var substitution = "[$1 $2$3 $4]"
fmt.Println(re.ReplaceAllString(str, substitution))
}