const regex = /\[\s*(https?:\/\/[^\]\s]+)\s+([^\[\]]*)\[\[([^\]\|]+)(?:\|[^\]]*)?\]\]\s+(.*)\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\s*(https?:\\\/\\\/[^\\]\\s]+)\\s+([^\\[\\]]*)\\[\\[([^\\]\\|]+)(?:\\|[^\\]]*)?\\]\\]\\s+(.*)\\]', 'gm')
const str = `[http://www.catalogueoflife.org/annual-checklist/2011/search/all/key/Typhlodromips+digitulus/match/1 Typhlodromips digitulus [[Catalogue of Life]] saytında]`;
const subst = `[$1 $2$3 $4]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);