import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\s*(https?:\\/\\/[^\\]\\s]+)\\s+([^\\[\\]]*)\\[\\[([^\\]\\|]+)(?:\\|[^\\]]*)?\\]\\]\\s+(.*)\\]";
final String string = "[http://www.catalogueoflife.org/annual-checklist/2011/search/all/key/Typhlodromips+digitulus/match/1 Typhlodromips digitulus [[Catalogue of Life]] saytında]";
final String subst = "[$1 $2$3 $4]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}