import Foundation
let pattern = #"\[\s*(https?:\/\/[^\]\s]+)\s+([^\[\]]*)\[\[([^\]\|]+)(?:\|[^\]]*)?\]\]\s+(.*)\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[http://www.catalogueoflife.org/annual-checklist/2011/search/all/key/Typhlodromips+digitulus/match/1 Typhlodromips digitulus [[Catalogue of Life]] saytında]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[$1 $2$3 $4]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)