$re = '/\[\s*(https?:\/\/[^\]\s]+)\s+([^\[\]]*)\[\[([^\]\|]+)(?:\|[^\]]*)?\]\]\s+(.*)\]/m';
$str = '[http://www.catalogueoflife.org/annual-checklist/2011/search/all/key/Typhlodromips+digitulus/match/1 Typhlodromips digitulus [[Catalogue of Life]] saytında]';
$subst = "[$1 $2$3 $4]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;