using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)([a-zA-Z]{2})([a-zA-Z]+)(\d{2})_(.*?)-metadata.xml";
string input = @"2016DKAOH9_026_planteportræt-3.pdf";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}