import re
regex = re.compile(r"(\d+)([a-zA-Z]{2})([a-zA-Z]+)(\d{2})_(.*?)-metadata.xml")
test_str = "2016DKAOH9_026_planteportræt-3.pdf"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")