const regex = /(\d+)([a-zA-Z]{2})([a-zA-Z]+)(\d{2})_(.*?)-metadata.xml/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)([a-zA-Z]{2})([a-zA-Z]+)(\\d{2})_(.*?)-metadata.xml', '')
const str = `2016DKAOH9_026_planteportræt-3.pdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}