import Foundation
let pattern = #"(\d+)([a-zA-Z]{2})([a-zA-Z]+)(\d{2})_(.*?)-metadata.xml"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2016DKAOH9_026_planteportræt-3.pdf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}