$re = '/(\d+)([a-zA-Z]{2})([a-zA-Z]+)(\d{2})_(.*?)-metadata.xml/';
$str = '2016DKAOH9_026_planteportræt-3.pdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);