#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^block )\w+\n"
Local $sString = "extends standard" & @CRLF & _
"" & @CRLF & _
"block head" & @CRLF & _
"" & @CRLF & _
" <title>title</title>" & @CRLF & _
" <meta name="description" content="A wonderful thing.">" & @CRLF & _
"" & @CRLF & _
"block body" & @CRLF & _
"" & @CRLF & _
" <h1>Title</h1>" & @CRLF & _
" <p>A wonderful paragraph...</p>" & @CRLF & _
"" & @CRLF & _
"block scripts" & @CRLF & _
"" & @CRLF & _
" <script src="/javascritps/html5shiv.js"></script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")