import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^block )\\w+\\n";
final String string = "extends standard\n\n"
+ "block head\n\n"
+ " <title>title</title>\n"
+ " <meta name=\"description\" content=\"A wonderful thing.\">\n\n"
+ "block body\n\n"
+ " <h1>Title</h1>\n"
+ " <p>A wonderful paragraph...</p>\n\n"
+ "block scripts\n\n"
+ " <script src=\"/javascritps/html5shiv.js\"></script>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}